Volvo Car Forums


Reply
Thread Tools Display Modes

volvo 960 1992 transmission problems

 
Masqqqqqqq
Guest
Posts: n/a
 
      08-08-2004
Volvo 960 wagon with automatic transmission. The car has a light on the
dash with an arrow, and 3 lights by the shifter, labelled 'E' , 'S', and 'W'.
Occasionaly the transmission goes through a spell (for a few days) of poor
shifting, jumpy takeoff, low top speed, inconsistent rpm, while the arrow light
on the dash blinks on and off, and the 'E' light and 'W' light by the shifter
alternate quickly. I've taken it to the garage, but as luck would have it, the
symptoms 'healed' on the way there, and the garage was unable to locate the
problem.
Any similar experiences, or ideas?
 
Reply With Quote
 
 
 
 
Peter Milnes
Guest
Posts: n/a
 
      08-08-2004
Check for loose connectors on the side of the gearbox. There are three. The
other thing to check is the W-S-E switch, when they go wrong they cause all
sorts of symptoms. I would check on the quality of the connections first.

Cheers, Peter.

"Masqqqqqqq" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
: Volvo 960 wagon with automatic transmission. The car has a light on the
: dash with an arrow, and 3 lights by the shifter, labelled 'E' , 'S', and 'W'.
: Occasionaly the transmission goes through a spell (for a few days) of poor
: shifting, jumpy takeoff, low top speed, inconsistent rpm, while the arrow
light
: on the dash blinks on and off, and the 'E' light and 'W' light by the shifter
: alternate quickly. I've taken it to the garage, but as luck would have it,
the
: symptoms 'healed' on the way there, and the garage was unable to locate the
: problem.
: Any similar experiences, or ideas?

 
Reply With Quote
 
 
 
 
Randy G.
Guest
Posts: n/a
 
      09-08-2004
(E-Mail Removed) (Masqqqqqqq) wrote:

> Volvo 960 wagon with automatic transmission. The car has a light on the
>dash with an arrow, and 3 lights by the shifter, labelled 'E' , 'S', and 'W'.
>Occasionaly the transmission goes through a spell (for a few days) of poor
>shifting, jumpy takeoff, low top speed, inconsistent rpm, while the arrow light
>on the dash blinks on and off, and the 'E' light and 'W' light by the shifter
>alternate quickly. I've taken it to the garage, but as luck would have it, the
>symptoms 'healed' on the way there, and the garage was unable to locate the
>problem.
> Any similar experiences, or ideas?



Mine does a similar thing, thinking it is in W mode (those three
letters are for "E"conomy- normal driving, "S"port which is a sportier
shifting mode with higher RPMs and faster downshifting (lots of fun in
the mountains), and "W"inter which is sort of like a granny low for
low traction surfaces- it decreases the torque to the rear wheels).
Mine goes into a sort of false neutral with very little power to the
rear wheels. It usually happens only when shifting into W mode and/or
shifting into 1st from 3rd. SOmetimes when shifting from P to N.

I got under the car anc thoroughly cleaned and silicons greased all
the connections I could, and it sort of seemd to help kind of. I am
assuming that it is my gear position switch (the pitchpipe switch on
the right side). To solve it I can turn the car one, allow the relays
to click and turn it off- usually three times does it (but not always-
can take four or five). Sometimes (but not always) wiggling the shift
lever helps as well.

SInce your is acting the way it is I would recommend a good mechanic.
If they know Volvo trannys they should be able to go to the problem
fairly easily. Since it is ocassional I would guess it is electrical.
__ __
Randy & \ \/ /alerie's
\__/olvo
'93 960 Estate
 
Reply With Quote
 
Mike F
Guest
Posts: n/a
 
      09-08-2004
"Randy G." wrote:
>
> (E-Mail Removed) (Masqqqqqqq) wrote:
>
> > Volvo 960 wagon with automatic transmission. The car has a light on the
> >dash with an arrow, and 3 lights by the shifter, labelled 'E' , 'S', and 'W'.
> >Occasionaly the transmission goes through a spell (for a few days) of poor
> >shifting, jumpy takeoff, low top speed, inconsistent rpm, while the arrow light
> >on the dash blinks on and off, and the 'E' light and 'W' light by the shifter
> >alternate quickly. I've taken it to the garage, but as luck would have it, the
> >symptoms 'healed' on the way there, and the garage was unable to locate the
> >problem.
> > Any similar experiences, or ideas?

>
> Mine does a similar thing, thinking it is in W mode (those three
> letters are for "E"conomy- normal driving, "S"port which is a sportier
> shifting mode with higher RPMs and faster downshifting (lots of fun in
> the mountains), and "W"inter which is sort of like a granny low for
> low traction surfaces- it decreases the torque to the rear wheels).
> Mine goes into a sort of false neutral with very little power to the
> rear wheels. It usually happens only when shifting into W mode and/or
> shifting into 1st from 3rd. SOmetimes when shifting from P to N.
>
> I got under the car anc thoroughly cleaned and silicons greased all
> the connections I could, and it sort of seemd to help kind of. I am
> assuming that it is my gear position switch (the pitchpipe switch on
> the right side). To solve it I can turn the car one, allow the relays
> to click and turn it off- usually three times does it (but not always-
> can take four or five). Sometimes (but not always) wiggling the shift
> lever helps as well.
>
> SInce your is acting the way it is I would recommend a good mechanic.
> If they know Volvo trannys they should be able to go to the problem
> fairly easily. Since it is ocassional I would guess it is electrical.
> __ __
> Randy & \ \/ /alerie's
> \__/olvo
> '93 960 Estate


Also, the flashing lights should leave codes.

http://www.brickboard.com/FAQ/700-90...onAutoAW30.htm

My brother's 960 had similar problems and 7! codes in the computer,
including 2 "unknown codes". (1997 model, required codes to be read
with a scan tool, unlike the 1992 (all up to 1995) that gives codes with
the diagnostic unit.) Replacing the gear position switch cured all.

--
Mike F.
Thornhill (near Toronto), Ont.

NOTE: new address!!
Replace tt with t (twice!) and remove parentheses to email me directly.
(But I check the newsgroup more often than this email address.)
 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer problems with my 1992 940 GL Don b. Volvo 940 13 08-05-2008 10:32 AM
Fuel pump problems 1992 740 wagon. Help needed? piergud@gmail.com Volvo 740 8 08-09-2006 10:21 PM
1992 volvo 960 rear shock absorber replacement Ralph Volvo 960 2 02-05-2005 11:01 AM
960 (1992) 3 litre engine oil leak. Ian Pellew Volvo 960 1 22-04-2004 01:45 AM
thinking of buying 1992 960 sedan Dan Finn Volvo 960 4 17-08-2003 03:30 AM


All times are GMT. The time now is 03:42 PM.