Classic Hard Start for 2000 S40

Discussion in 'Volvo S40' started by Kyle Ferguson, Feb 10, 2016.

  1. Kyle Ferguson

    Kyle Ferguson

    Joined:
    Feb 10, 2016
    Messages:
    1
    Likes Received:
    0
    I have the classic hard start issue for my 2000 S40, but it is not fixed by replacing the fuel pressure regulator. Symptoms are as follows:

    1. When engine is cold, it will crank for upwards of 10 seconds before reluctantly coming to life.
    2. After starting engine runs fantastic. No hesitation or stalling. (See caveat on #3)
    3. After driving a couple of blocks, engine will rev up slightly with light or no throttle input... causing sphincter tightening if coming to a stop.
    4. Replaced Idle Air Control Valve a couple of years ago. (I don't think this is the issue since the fix for this was to simply hit the gas a bit)
    5. Replaced the Fuel Pressure Regulator. Had no effect.
    6. Let fuel pump run before cranking (to see if lack of pressure at the rail was an issue)
    7. Spark plugs look great.
    8. Fuel pressure and flow rate are great.
    9. I have a P0118 and P0128. Are these related to issue? I've had these codes for a long while, and this hard start issue appeared out of thin air last week. I'm going to replace the thermostat and Coolant Temp sensor tomorrow.
    Any help would be great!
     
    Kyle Ferguson, Feb 10, 2016
    #1
    1. Advertisements

  2. Kyle Ferguson

    CARiD

    Joined:
    Feb 16, 2016
    Messages:
    5
    Likes Received:
    1
    After driving a couple of blocks, engine will rev up slightly with light or no throttle input...

    This can be also caused by a throttle cable, it can be warn out or simply doesn't move free.
     
    CARiD, Feb 17, 2016
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.