1995 Volvo 960 wagon

Discussion in 'Other Volvo Models' started by Greg Barker, Sep 28, 2017.

  1. Greg Barker

    Greg Barker

    Joined:
    Sep 28, 2017
    Messages:
    1
    Likes Received:
    0
    Hi!

    First timer. Want to join 960 forum, but did not see it as a choice?
    I know there are a few 960 wagons around with IRS, but they are
    old enough to be mostly gone.
    My first question is about rough running.
    This wagon has 192K and I have driven it the last 50K.
    It has been reliable until now, and always runs great, But Yesterday it
    almost didn't make it home. Pulled codes and got 2-1-2 on A2, so I
    replaced the front oxy sensor with a Bosch 15738 (75-2674) which
    I was informed was supposed to be the replacement?
    Reset A1 to 1-1-1, and A2 to same, but A3 stays with 1-5-2?
    I can't seem to reset it to 1-1-1?
    The engine now idles fine, but when I attempt to give it throttle in neutral,
    it acts lean and sometimes sounds like it is backfiring into air cleaner.
    I'm hesitant to drive it because that was what it sounded like when it
    almost didn't make it home? Plugs replaced 10K ago.
    Any suggestions as to what to pay attention to?

    And, have been hearing noise from passenger (right) front headlight. Found
    a box with a 3 wire connector, disconnected it, and noise went away.
    Cannot figure out what it is. Anyone know?
     
    Greg Barker, Sep 28, 2017
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.