2003 V70 Base - Check Engine Light and no start

Discussion in 'Volvo V70' started by ParkhillRob, Apr 26, 2014.

  1. ParkhillRob

    ParkhillRob

    Joined:
    Apr 26, 2014
    Messages:
    1
    Likes Received:
    0
    Hi.
    I have a 2003 V70 Base 2.4L V5 non-turbo with Bosch electronics manufactured in Belgium.

    When the car started to sputter and die when you started the car and lightly pressed the accelerator, that symptom and others led me to believe that the Mass Air Sensor (MAS) was on the fritz. Everyone said that you could at least start the car again to get it going and get home....eventually

    I bought some sensor cleaner and cleaned out the MAS. Now, even though the dealer said it required a Bosch MAS, the car had a Denso. Not sure if that matters.

    But now, I tried to start the car, and the starter just tries and tries but no ignition at all - the starter just spins the motor.

    If it were just a MAS issue, I thought you could start the car again and that it would still sputter and be rough.

    With the check engine light on, would a BROKEN MAS prevent it from firing?

    What WOULD prevent a car with the emissions check engine light and the 'Engine System Service Required' message on from starting?

    I need to get this car to the dealer and I live in the country. I don't cherish the idea of towing the car some 60 Kms...

    Any help/insight appreciated!


    R
     
    ParkhillRob, Apr 26, 2014
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.