4th gear disengagement issue

Discussion in 'General Motoring' started by Norbs, Oct 15, 2003.

  1. Norbs

    Norbs Guest

    Hi there,

    Just inherited an '89 740 Turbo automatic and I'm having trouble getting the
    fourth gear in place when I depress the 4th gear button located at the side
    of the shift selector. I'd would usually depress it many times before the
    shift indicator light on the dash goes off and the tranny shifts into 4th
    gear. There's about a 1000 - 1200rpm difference at speeds of 100/kph so in
    terms of mileage I'd really like to get this solved. I do hear a faint
    clicking I've noticed everytime I depress the button but in doesn't always
    work.

    Does anyone have a suggestion as to where I should start or diagnose?

    Thanx,

    Norbert
     
    Norbs, Oct 15, 2003
    #1
    1. Advertisements

  2. Norbs

    Rob Guenther Guest

    Clicking would be caused by a relay being activated, the shift not working
    would be the overdrive solenoid, it probably needs replaceing. I have seen
    this problem posted many times before, its either the solenoid, the relay,
    or the wiring is damaged. Failing that, it's the switch contacts.
    Since the relay clicks, it probably is working fine, but if you do the
    solenoid, you may as well get a new relay.
     
    Rob Guenther, Oct 19, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.