My 960 is having heat stoke or some such thing

Discussion in 'Volvo 960' started by Damien, Jan 21, 2007.

  1. Damien

    Damien Guest

    Well folks it is time to move on to my 960. Now I live in Brisbane Australia
    and it is a hot dry summer here at the moment. The days are usually in the
    mid 30's deg C.

    The problem is when I leave the car in the heat of the day and drive the car
    at say 11 am, the windows and the blinkers don't work. If I drive it for
    awhile then stop and restart the car they work.

    Any idea which bit is getting affected by the heat?



    Thanks for your help



    Damien
     
    Damien, Jan 21, 2007
    #1
    1. Advertisements

  2. Damien

    James Sweet Guest


    I'd start by checking the fuse box and the relays, could be a loose
    connection that the heat is expanding.
     
    James Sweet, Jan 21, 2007
    #2
    1. Advertisements

  3. Damien

    Volvo Guy Guest

    my 960 does the same thing in Texas HOT I found out the ing, switch
    wasnt returning all the way after starting
    just turn it slightley back from start to run. It is like there is a
    dead spot in there that doesnt make contact with the assories.
     
    Volvo Guy, Jan 22, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.